Blog

Skip to content

Upgrading to FCMS 2.6

There is a bug in the original automatic upgrade script.

Upgrading to Family Connections 2.6

Upgrading from 2.5.3 or earlier

1. Upgrade to 2.5.4
2. Follow instruction: Upgrading from 2.5.4

Upgrading from 2.5.4

1. Log in as admin

2. Run the automatic upgrade

3. The upgrade will stop on step 4 with the following error message:

Could not find upgrade directory.

To continue the upgrade process change the url from auto=4 to auto=5.  This will continue on with step 5 of the process

4. When the upgrade is finished, click the logo to return to the website.

Be Sociable, Share!

Categories: News.

Comment Feed

4 Responses

  1. What happened to fixing the family tree dates feature? The current format DESTROYS family tree data for people with unknown and/or partial data. Since this was planned for version 2.6 I told the people who have been asking for that fix to expect it. What do I tell them now???

    Mark Richard WatsonNovember 2, 2011 @ 11:17 am
  2. Also, there are more errors in the “Last 5 by section” than there were when I first reported them. The ONLY change I see: it is now harder to re-code in my recaptcha. Perhaps you should add bluehost to the list of hosts that your scripts have problems on. I am back to searching for a genealogy CMS that will make my family happy, and a way to migrate them over from THIS cms.. From the amount of automated registrations recently, I would say this one has some security issues as well as other instabilities that get worse with each release. Even with recaptcha, the bots were getting through.

    Mark Richard WatsonNovember 2, 2011 @ 11:29 am
  3. I’m sorry Mark, the family tree date feature was moved to FCMS 2.7.

    This is so I could meet the new monthly release cycle.

    I am not aware of any issues with the “Last 5 (by section)” view. What exact problems are you having?

    I’m not sure why you are having trouble with registrations. Captcha should not be necessary. Each user needs to activate their account through a valid email address. You can also turn off registration completely.

    Bots should never be able to login to your site.



Some HTML is OK

or, reply to this post via trackback.

Continuing the Discussion

  1. […] NOTE: Before you upgrade, please read this post about upgrading to FCMS 2.6. […]